photo

Anonymous

shared this question
6 years ago

Employees Involved

photo

Ryan Bonham

Admin

photo

PIV Support

Admin

Statistics

7
Comments
3069
Views

Relates to

Share

3
votes

Big problem with Magic_quotes_gpc installing Open Realty

I'm installing Open Realty on a web hosting, i'm in installation process but i recieve the next error:

- You have "magic_quotes_gpc" actually set to "ON" at your server while you should have it set to "OFF". Contact your host support and ask to turn it off.

I'm disabling magic quotes on php.ini, and for being sure, i made a phpinfo.php file with the info of the modules of web host, and i get this:

magic_quotes_gpc Off Off

magic_quotes_runtime Off Off

magic_quotes_sybase Off Off

How is possible?? My php info file says that magic quotes are off, and the openrealty installation tells that is ON, i dont know what to do... Thanks for the help

Add Comment

Comments (7)

photo Employee
Best Response 1

Paul,

Your solution, does not work on all cPanel based servers. It depends on how the host is running PHP. In fact entering that into an .htaccess file on some host will result in a 500 internal server error.

The proper solution here is to contact your host for assistance in turning off magic_quotes for your account. Your host can turn magic_quotes, or any other php setting, on & off on a per account basis. This should only take them a minute or two to do, if they are unable to do this then you should find a new host that knows how to properly manage their servers.

photo Employee
0

Had you first done a search here, you would see this is a common problem and the solution has been provided many times. The solution is to have your host turn it off for your entire hosting account.

What you are doing turns it off for just the folder you have placed your php.ini file in, it needs to be turned off for all folders.

photo
1

There is actually a second answer to this. If you have shared hosting your provider will probably refuse to globally turn magic off. Their rationale is that it is going to impact multiple accounts whose settings may actually be dependent upon it even though it isn't even valid in php anymore.

If you have cpanel, simply open the .htaccess file in one of two areas:

  • First, if you only want to impact the Open Realty package, open the directory it is in and enter this:

    #Turn Off Magic Quotes

    php_flag magic_quotes_gpc Off

  • If you want to apply this action globally for your entire site, simply enter the same thing; however, place it in your root (public_html) area

photo Employee
1

Paul,

Your solution, does not work on all cPanel based servers. It depends on how the host is running PHP. In fact entering that into an .htaccess file on some host will result in a 500 internal server error.

The proper solution here is to contact your host for assistance in turning off magic_quotes for your account. Your host can turn magic_quotes, or any other php setting, on & off on a per account basis. This should only take them a minute or two to do, if they are unable to do this then you should find a new host that knows how to properly manage their servers.

photo
1

I am trying to install OpenRealty to demo it to a client, I am getting the magic_quotes_gpc is on error... My server is a mamaged dedicated server, magic_quotes_gpc is disabled, info.php shows this verifying that I disabled it correctly in the php.ini for the domain on the server. It also does not work using .htaccess, I get the internal server error. Since I have managed support, I talked to them and was told that I had disabled it correctly.

Attached is a pdf showing what the info.php files shows for the domain.

Anyone have any ideas as to what is going on?

photo Employee
1

If the OR installer is complaining magic_quotes is turned on, it still is. OR uses PHP to check this value.

You need to turn magic_quotes off globally for the entire hosting account and not just for the document root folder. Copy your 'info.php' file to any sub folder in your OR installation and run it from there and you will see magic_quotes is still turned on.

if you don't know how to turn this off for the entire hosting account, speak with your host.

photo
1

This did not work for me, by turning off magic_quotes - it wrecked other sites on my account, so far, can't get it resolved. Not happy

photo Employee
1

Any software that cannot operate with PHP magic_quotes turned off, needs to be upgraded immediately, it is a legacy feature that was deprecated long ago and has been discontinued entirely in PHP v5.4.

Leave Comment

photo

Attach files...

The file must be a jpg, gif, png, bmp, ico, pdf, doc, rtf, txt, zip or rar no more than 20M