photo

jordi

shared this problem
7 years ago

Employees Involved

photo

Ryan Bonham

Admin

Statistics

6
Comments
321
Views

Relates to

Share

1
votes

maximum field length not working

I am trying to set up a listing field (textarea) with a maximum field length, but it doesn't work. Whether I copy or type text into the field, the length is not restricted. It is set at the database though. I came acroos a thread from 2009 where some people had the same problem. Version now is 3.1.6.

Add Comment

Comments (6)

photo
0

Are you sure the template tag {textarea_#_short} is placed at your template file?

Maybe I missunderstood your question... do you mean the value set while editing the listing field, right? I will make a test with my installation.

photo
0

Yeah, I confirm what you say.Using Listing Field Editor, the "maximum field length" is not working. I have tested with an existent listing and with a new listing.

This ticket is being reported to TTech as a bug.

photo
0

thanks very much!

photo Employee
0

When you go to save the listing, you should be seeing a message next to the field, such as "Please enter no more than 5 characters." if you have exceeded the field length. I just tested this on my local install and it is working.

photo
0

Nope! :) You can test my demo installation if you wish. I went to Listing Field Editor and set "Full Description" to have a max of 15. I have edited an existent listing with "Exclusive to this site! For two hundred years, the White House has stood as a symbol of the Presidency, the United States government, and the American people." - also created a new listing with the same text and did not get any message - the listings were saved with that text.

photo Employee
0

Ok. I can confirm that the max length setting does not work with textarea fields, i tested with a text field originally.. I will fix this for the next release.

Leave Comment

photo

Attach files...

The file must be a jpg, gif, png, bmp, ico, pdf, doc, rtf, txt, zip or rar no more than 20M